
Microsoft Visio 
 

Open templates 

You begin a Microsoft Office Visio diagram with a template—a file that opens one or more stencils that contain 
the shapes you need to create your diagram. Templates also include the styles, settings, and tools appropriate 
for the drawing type.  

Open a template 

1. On the File menu, point to New, and then click Choose Drawing Type.  
2. In the Choose Drawing Type window, under Category, click Flowchart.  
3. Under Template, click Basic Flowchart. 

Add shapes 

Add shapes to your diagram by dragging shapes from stencils in the Shapes window onto the drawing page.  

Drag shapes from a stencil 

1. From the Basic Flowchart Shapes stencil in the Shapes window, drag a Process shape onto the drawing 
page.  

2. Drag another Process shape and place it below the first Process shape.  
3. Drag a Decision shape and place it below the second Process shape.  
4. Drag a Predefined process shape and place it to the right of the Decision shape.  
5. Drag another Process shape and place it below the Decision shape.  
6. Drag a Terminator shape and place it below the last Process shape. 

Delete shapes  

Deleting shapes is easy. Just click the shape and then press the DELETE key. 

Note   You can't drag shapes back onto a stencil in the Shapes window to delete them. 

Delete a shape 

• Click the last Process shape in your diagram, and then press the DELETE key. 

Find shapes 

You can look for more shapes on other stencils. 

Open a stencil 

1. On the File menu, point to Shapes, point to Flowchart, and then click Miscellaneous Flowchart Shapes.  
2. From the Miscellaneous Flowchart Shapes stencil in the Shapes window, drag the Process (circle) shape 

onto the drawing page and place it to the right of the first Process shape.  
3. In the Shapes window, click the Basic Flowchart Shapes stencil title bar to show its shapes again. 

Zoom in and out of the drawing page 

If the shapes in your diagram are too small to work with, you'll want to zoom in closer. If you're working with a 
large diagram (for example, a site plan or floor plan) you may need to zoom out to check the overall view. 



Zoom in and out of the drawing page 

1. To zoom in on the shapes in your diagram, click the Pointer tool , and then hold down the 
CTRL+SHIFT keys while you drag a selection rectangle around the shapes.  

The pointer changes to a magnifying tool , which tells you Microsoft Office Visio is ready to zoom in 
on the shapes. 

2. To zoom out to check the overall look of your diagram, center the drawing page in the window, and 
press the CTRL+W keys. 

Move one shape 

Moving a shape is easy: just click any shape to select it, and then drag it to a new location. Selection handles 
appear when you click the shape.  

Move one shape 

1. With the Pointer tool , click the Process (circle) shape to select it.  
2. Place the Pointer tool over the center of the Process (circle) shape.  

A four-headed arrow appears under the pointer , which tells you that the shape is ready to be 
moved.  

You don't have to place the Pointer tool exactly over the center of the shape; but it's a good habit to 
develop so you don't drag a shape handle and resize the shape by mistake.  

3. Drag the Process (circle) shape next to the second Process shape.  

If you resize the shape by mistake, just undo your last action. (On the Edit menu, click Undo.) 

Note: You can click a shape, and then press an arrow key on your keyboard to move it. To move the 
shape in smaller increments, hold down the SHIFT key while you press an arrow key. 

Move multiple shapes 

To move more than one shape at a time, you first select all the shapes you want to move.  

Move more than one shape at a time 

1. With the Pointer tool  , click a blank area of the drawing page above and to the left of the top 
Process shape, and then drag to create a black selection rectangle around all of the shapes, except for 
the last Terminator shape.  

Alternatively, you could hold down the SHIFT key while you click each shape.   

2. Place the Pointer tool over the center of any of the selected shapes.  

A four-headed arrow appears under the pointer , which tells you that the shapes are ready to be 
moved. 



3. Drag the shapes down a little bit to make room for your diagram title.  

All the selected shapes move at once.  

Resize shapes 

You can resize shapes by dragging their corner, side, or bottom selection handles. 

Note   Microsoft Office Visio shapes have other types of handles, as well, such as rotation and control handles. 
You'll learn about these handles in other lessons.  

Resize a shape 

1. With the Pointer tool , click the Process (circle) shape.  
2. Place the Pointer tool over a corner selection handle .  

The pointer changes to a two-headed arrow , which tells you that the shape can be resized. 

3. Drag the selection handle inward to decrease the size of the shape. 

Add text to shapes 

You can add text to shapes. Just click a shape and begin typing; Microsoft Office Visio zooms in so you can see 
the text as you type.  

Add text to shapes 

1. Click the first Process shape on the drawing page, and then type 1.  

Alternatively, you could click the Text tool , click the shape, and then type. 

2. Click the second Process shape, and then type 2.  
3. Click the Decision shape, and then type 3.  
4. Click the Predefined Process shape, and then type A.  
5. Click the Terminator shape, and then type B.  
6. Click a blank area of the drawing page or press the ESC key to exit the text mode. 

Add independent text 

You can also add text that's not associated with any shape, such as a title or list, to the drawing page. This type 
of text is called independent text or a text block. Use the Text tool to just click and type. 

Add independent text 

1. Click the Text tool .  
2. Click the top of the page, and then type 123AB. 

Move independent text 

You can move independent text as you move any other shape: just drag it. In fact, independent text is really 
just a shape with no border or color. 

Move independent text 



1. With the Pointer tool , click the text.  
2. Place the Pointer tool over the center of the text.  

A four-headed arrow appears under the pointer , which tells you that the text can be moved, just like 
any other shape. 

3. Drag the text to center it above your diagram.  
4. Press the CTRL+W keys to zoom out and check the overall look of your diagram. 

Format text 

You can format text—italicize it, underline it, center it, and so on—the same way you format text in any Microsoft 
Office System program. You can use buttons on the toolbar or options in the Text dialog box (on the Format 
menu). 

Format text 

1. To show text formatting buttons, right-click the toolbar, and then click Format Text on the shortcut 
menu.  

2. Click somewhere above and to the left of the top Process shape and the diagram title, and then drag a 
black selection rectangle that encloses all of the shapes.  

Everything within the selection rectangle is selected. 

3. To increase the size of the text to 14 points, click the Increase Font Size button on the Format Text 
toolbar four times. 

Connect shapes with the Connector tool 

You use the Connector tool to create connections. 

Note   People new to Microsoft Office Visio often use the Line tool to connect shapes. Using the Connector tool 
is a much better method. When you use the Connector tool, connectors reroute, or bend, automatically when 
you move one of the connected shapes. When you use the Line tool to connect shapes, the connectors don't 
reroute. 

Connect shapes with the Connector tool 

1. To zoom in on the top two shapes, hold down the CTRL+SHIFT keys while you drag a selection 
rectangle around the shapes.  

2. Click the Connector tool .  
3. Place the Connector tool over the connection point on the bottom of the first Process shape.  

The Connector tool highlights the connection point with a red box , which tells you that a connection 
can be made at that point. 

4. Drag the Connector tool from the connection point on the first shape to the connection point at the 
top of the second Process shape.  

The connector endpoints turn red when the shapes are connected. This is an important visual cue. 
If one of the connector's endpoints is still green , use  the Pointer tool to connect the endpoint to the 
shape. Both endpoints must be red if you want the shapes to stay connected. 



5. To zoom out, press the CTRL+W keys.  
6. Connect the rest of the shapes in the order shown in the animation (second Process shape to Decision, 

Decision to Terminator, Decision to Predefined process, and finally Predefined process to Terminator).  

7. With the Pointer tool , click the top Process shape to select it, move the shape to the right a little, 
and then move it back. Notice that the text moves with the shape and the connector reroutes and 
remains connected to the two shapes.  

The connector reroutes because you used the Connector tool to connect the shapes. 

Connect shapes with connectors from stencils 

You can also connect shapes with connectors from stencils. For example, in a block diagram, you can drag two-
dimensional arrows from a stencil and connect them to boxes.  

Connect shapes with a connector from a stencil 

1. From the Basic Flowchart Shapes stencil in the Shapes window, drag the Line-curve connector, and 
position it so the endpoint of the plain end of the connector connects to the connection point on the 
left side of the first Process shape.  

The Line-curve connector endpoint turns red when it is connected to the Process shape. The other 
endpoint is still green because you haven't connected it to a shape yet. 

2. Drag the other endpoint of the arrowhead end of the Line-curve connector onto the connection point 
on the left side of the Decision shape.  

Both connector endpoints turn red when the shapes are connected. 

Add text to connectors 

You can use text with connectors to describe relationships between shapes. Add text to connectors the same 
way you add text to any shape—just click a connector and type. 

Add text to connectors 

1. With the Pointer tool , click the connector between the Decision and Predefined process shapes, 
and then type A.  

Microsoft Office Visio zooms in so you can see the text as you type. 

2. Click the connector between the Decision and Terminator shapes, and then type B. 

Add shapes between connected shapes 

If you want to add a new shape between two connected shapes, you can. Just drag the new shape on top of 
the connector, and all three shapes automatically connect. 

Note   This works in the flowchart, electrical engineering, and process engineering templates. 

Add a shape between connected shapes 



• With the Pointer tool , drag the Process (circle) shape onto the connector between the Predefined 
process shape and the Terminator shape.  

Microsoft Office Visio connects the Predefined process shape to the Process (circle) shape, and the 
Process (circle) shape to the Terminator shape. 

Format 2-D shapes 

1. To change the color of the Decision shape, click it, click the Fill Color button on the toolbar, and then 
click Bright Green.  

Alternatively, on the Format menu, click Fill to change the fill color or pattern. 

2. To change the line color of the Predefined process shape, click it, click the Line Color button button 
on the toolbar, and then click Red.  

Alternatively, on the Format menu, click Line to change the line color, thickness, or pattern. 

 

Format a 1-D shape 

• To change the line pattern of the Line-curve connector shape, click it, click the Line Pattern button on 
the toolbar, and then select a dashed line.  

Alternatively, on the Format menu, click Line to change the color, thickness, pattern, or ends. 

Change how shapes look with control handles 

Some shapes have control handles you can use to change the shape appearance. For example, a control 
handle might rotate a shape, move the lines inside a shape, increase the size of a pie chart slice, or change the 
location of the text associated with the shape.  

Change how shapes look with control handles 



1. To decrease the distance between the inside lines of the Predefined process shape, with the Pointer 

tool , drag the control handle on the shape inward.  

To find out what a control handle does, pause the pointer over the control handle to see a tip.  

2. To widen the curve of the Line-curve connector shape, drag the control handle on the shape to the left. 

Save diagrams 

After you finish a diagram, you can save it the same way you save a file created in any Microsoft Office System 
program.  

Note   It's a good idea to periodically save your diagram as you work.  

Save a diagram 

1. On the File menu, click Save As.  
2. In the File name box, type Flowchart, and then click Save. 

Preview and print diagrams 

Before you print a diagram, you can preview it to ensure it will print correctly. In the Print Preview window, the 
gray boundary indicates the drawing page margins and edge of the printed page. Shapes that overlap this 
boundary won't print completely. Either move them or adjust your drawing page or printer settings, such as 
orientation, size, or margins. (To adjust page or printer settings, on the File menu, click Page Setup.) 

Preview and print a diagram 

1. On the File menu, click Print Preview.  

Alternatively, you can click the Print Preview button . 

2. On the File menu, click Print.  

If you only want to print the current drawing page, you can click the Print Page button instead. 

3. In the Print dialog box, click OK.  
4. To exit print preview, on the toolbar, click Close. 

 
Create Organizational Charts 
 

Open the Organization Chart template 

The Organization Chart template opens several stencils including the Organization Chart Shapes stencil, which 
contains all the shapes you need for any size organization chart.  

The Organization Chart template also includes the Organization Chart menu and toolbar, which provide tools 
to help you lay out, synchronize, hide, and move the shapes in your chart, plus other tools to help you create, 
manage, import, and export organization information.  

Open the Organization Chart template 



1. On the File menu, point to New, and then click Choose Drawing Type.  
2. Under Category, click Organization Chart, and then under Template, click Organization Chart. 

Add the first shape to an organization chart 

The first shape you add to an organization chart is the top shape in the hierarchy, which usually represents an 
executive. However, it could represent a manager or project leader if you're creating an organization chart for 
a single department or team. 

Add the first shape to the organization chart 

1. From the Organization Chart Shapes stencil in the Shapes window, drag an Executive shape onto the 
drawing page.  

2. As you drag the shape onto the drawing page, the Connecting Shapes dialog box may appear. Select 
the Don't show this message again check box, and then click OK. 

Create organization hierarchies 

You connect the shapes and create the organization hierarchy in an organization chart by dragging shapes on 
top of each other.  

For example, when you drag a Position shape on top of a Manager shape, Microsoft Office Visio places the 
Position shape below the Manager shape and connects the two. 

Create the organization hierarchy 

1. From the Organization Chart Shapes stencil in the Shapes window, drag a Manager shape onto the 
Executive shape on the drawing page.  

Visio arranges and connects the two shapes. 

2. Drag three Position shapes, one at a time, as shown in the animation, on top of the Manager shape on 
the drawing page.  

Visio arranges the Position shapes below the Manager shape and connects them to the Manager 
shape. 

3. To change the layout of the shapes below the Manager shape, click the Manager shape. On the 
Organization Chart toolbar, click the Horizontal Layout button , and then click the Stagger button .  

Note: You can show employee photographs and other information, such as 
telephone number and e-mail address, in your organization chart shapes. To show 
an employee photograph, right-click a shape, and then click Insert Picture on the 
shortcut menu. To show more employee information, on the Organization Chart 
menu, click Options. In the Options dialog box, click the Fields tab, and then specify 
the information you want to show and where you want to show it. 

 

 


